Scala command is throwing run time excpetion


#1

I have created person class as shown below and I am trying to find the corresponding java code by using :Javap command .
I have not been able to find java code as I am getting below error .I have searching the solution for this error for few days now but I don’t have any luck .
so could you suggest something that I can look for . Thanks for taking your time and looking in to this in advance .

Note - The environment variables are set correctly for both java and scala in my system .


#2

Are you able to run the regular javap command in a bash/cmd/… shell?


#3

Hi Jasper

I am sorry but I don’t understand what you mean by “Regular Javap Command”
If you mean that am I able to run :javap command with out any argument ?
So in my above example :javap person . I have tried this as well and I am getting same run time exception .


#4

javap is a command line tool of the JDK. The :javap command of the Scala REPL reuses the underlying machinery. So if the javap command line tool is not available or doesn’t work it’s probably an issue with your JDK setup.


#5

Thanks Japser . it worked .

just for future reference , I had set up JDK environment variable but not JRE after setting up both JDK and JRE environment variable in my system :javap is working fine .