Can't turn off Mailing List Mode in Settings

I just registered here a couple of days ago and strangely enough I was spammed a lot of unnecessary e-mails, resulting from tons of notifications created here on this forum.

I went into my profile preferences, toned down the settings and finally turned of Mailing List Mode, as apparently this was causing the immense spam.

Now, to double check, I went back to my profile preferences and saw that Mailing List Mode was still turned on. I turned it off again, checked back and saw it has once again been overriden, as it apparently is forced globally onto every user.

How can I turn off Mailing List Mode for good? I’d have to basically discard all e-mails from this forum, if I wanted to stop getting spammed when Mailing List Mode stays on, which means I would also discard e-mails that are actually worth interacting with.

The default setting for every Discourse forum I have been on (which is tons) is having it turned off. That’s why this is the only Discourse forum that creates this issue.

Does this mean also, everyone get’s this topic as an e-mail sent to them? :laughing:

Mailing list mode is at least not forcibly enabled, I can turn it on and off again and the choice is preserved when leaving the settings.

Do you get the “Saved!” when clicking on “Save Changes”? If not, is javascript enabled?

Yes. Yes.

It is “saved”, but when I return to the preferences, it gets overriden automatically:

Always getting that banner, when returning to the preferences page.

Okay, I saved it 3 times in a row now, and the third time it seems to actually work now. I hope it stays that way and does not get changed back, as it did before, hours ago.

Anyway, thank you for helping! :grinning_face_with_smiling_eyes: