Activator stage

I try to reinstall a scala project from 5 years ago. I have installed a new LINUX machine, but, when running:

activator stage

I get the following message:

[info] welcome to sbt 1.8.2 (Oracle Corporation Java 1.8.0_361)
[info] loading settings for project meteora_be-build from plugins.sbt …
[info] loading project definition from /home/amerchan/meteora_be/project
[error] insecure HTTP request is unsupported ‘’; switch to HTTPS or opt-in as (“typesafe-releases” at “”).withAllowInsecureProtocol(true), or by using allowInsecureProtocol in repositories file

What could be the problem? Thanks for your help. I have little experience with these tools


Your build uses an HTTP connection instead of HTTPS, which was deprecated in sbt.

If you added the typesafe repo via the Resolvers.typesafeRepo method, which should add the HTTPS version, the problem may also be your Java version according to this StackOverflow post, because of missing certificates in versions before JDK 11 (it looks like you’re still on JDK 8 from the logs).

If you can’t change to a newer JDK for some reason, maybe it’s possible to add the missing certificates, or you may opt out of HTTPS by replacing the typelevel repo definition in your build with the one from the error message, (“typesafe-releases” at “”).withAllowInsecureProtocol(true).

1 Like

Thank you very much for the answer. I have already updated the JDK, and now I have new problems:

[amerchan@localhost meteora_be]$ rm ~/.sbt/repositories
[amerchan@localhost meteora_be]$ activator stage
[info] welcome to sbt 1.6.0 (Oracle Corporation Java 20)
[info] loading settings for project meteora_be-build from plugins.sbt …
[info] loading project definition from /home/amerchan/meteora_be/project
[info] Updating
[info] Resolved dependencies
[warn] Note: Some unresolved dependencies have extra attributes. Check that these dependencies exist with the requested attributes.
[warn] com.typesafe.sbt:sbt-rjs:1.0.7 (sbtVersion=1.0, scalaVersion=2.12)
[warn] com.typesafe.sbt:sbt-mocha:1.1.0 (sbtVersion=1.0, scalaVersion=2.12)
[warn] com.typesafe.sbt:sbt-digest:1.1.0 (sbtVersion=1.0, scalaVersion=2.12)
[warn] com.typesafe.sbt:sbt-jshint:1.0.3 (sbtVersion=1.0, scalaVersion=2.12)
[warn] (sbtVersion=1.0, scalaVersion=2.12)
[warn] com.typesafe.sbt:sbt-native-packager:2.4.0 (sbtVersion=1.0, scalaVersion=2.12)
[warn] com.typesafe.sbt:sbt-coffeescript:1.0.0 (sbtVersion=1.0, scalaVersion=2.12)
[warn] com.typesafe.sbt:sbt-less:1.0.6 (sbtVersion=1.0, scalaVersion=2.12)
[warn] Note: Unresolved dependencies path:
[error] sbt.librarymanagement.ResolveException: Error downloading com.typesafe.sbt:sbt-rjs;sbtVersion=1.0;scalaVersion=2.12:1.0.7
[error] Not found
[error] Not found
[error] not found:
[error] not found: /home/amerchan/.ivy2/localcom.typesafe.sbt/sbt-rjs/scala_2.12/sbt_1.0/1.0.7/ivys/ivy.xml
[error] not found: /opt/activator-dist-1.3.10/repository/com.typesafe.sbt/sbt-rjs/scala_2.12/sbt_1.0/1.0.7/ivys/ivy.xml
[error] not found: JFrog
[error] not found: JFrog
[error] not found:
[error] not found: JFrog
[error] Error downloading com.typesafe.sbt:sbt-mocha;sbtVersion=1.0;scalaVersion=2.12:1.1.0
[error] Not found

What is missing?

I’m afraid I can’t help, never worked with Typesafe Activator, but my impression is that this tool just silently died - at least all links to documentation, github project, etc., seem to point nowhere these days.

If this impression is correct, the best course of action probably is to drop Activator and manually rework your project into a vanilla sbt project.

1 Like

I’m surprised to see that the sunsetting of Activator isn’t covered in the Play 2.6 migration guide (Highlights26 - 2.8.x) — 2.6 seems to be the version where it was dropped.

According to ,

“The main thing Activator supported that sbt didn’t was creating new projects from templates and a browser based “IDE”. The template part at least is now supported by sbt: sbt Reference Manual — sbt new and Templates. At runtime sbt and Activator are identical, so you should be fine for production.”

So maybe there’s nothing to migrate, maybe just use sbt and it’s fine?

Yeah - my experience was that the practical differences between Activator and sbt were nil. When Activator went away, I just switched my processes to use sbt instead, and it just worked, (Indeed, IIRC, I just aliased sbt to activator and changed nothing else.)