SBT on Fedora Linux


When I install SBT 0.13.12 on Fedora Linux, I can invoke it simply by command “sbt”.

But when I upgrade to 0.13.13 or 0.13.15, no command seems to be available.

Any idea? Thanks!

 Best, Oliver

By what method are you installing/upgrading sbt?


dnf, the default package manager for Fedora.

Actually, my system keeps notifying me that SBT is ready to upgrade, and
when I do so, I lose the sbt command. Then, it tells me that SBT version
0.13.12 provides that command, which is ready to install, but only after
removing the newer version.

 Best, Oliver

Ah — a problem with how Fedora packages sbt, then, rather than a problem with sbt itself.

Hopefully a Fedora user can help you, or maybe you’ll need to bring it up with the maintainers of the Fedora package.

The official sbt package in Fedora is stuck at version 0.13.1, so I’m guessing you are using the bintray repository? (you can check with dnf repolist, and dnf should also show you which repository an update is coming from when using dnf upgrade)

What happens if you first completely remove sbt with dnf remove sbt and then install it from scratch with dnf install sbt?

I’ll see if I can reproduce this on a Fedora 25 later today…




Interesting, remove/install worked. I thought I had tried that one
before. Thanks!

Small anomaly: according to the names of the files downloaded, it must be
SBT 0.13.15, but sbtVersion is set to 0.13.13.

Yes, I’m getting SBT from Bintray.

 Best, Oliver