Install Scala3 using Coursier fails Windows 10


(lots of text first)
Wrote scala3-compiler
Warning: C:\Users\stl\AppData\Local\Coursier\data\bin is not in your PATH

Sort of a bad first impression, I think. Tried using cmd as admin and normally. Same result.
Running “scala3” command then failed.

Added the missing path to PATH manually, now giving this result:
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Users\stl\AppData\Local\Microsoft\WindowsApps;C:\Users\stl\AppData\Local\Coursier\data\bin;

‘""’ is not recognized as an internal or external command,
operable program or batch file.

That’s where the first hour of my installation process went. Any idea what to do next?

1 Like


Seems like you don’t have a JRE installed.

Running cs java-home should list your current JRE, if installed, or install the default JRE.

Then, ensure to set JAVA_HOME variable to the path output by the cs java_home command.