Errors building with Scala 2.12

Hello all. I have a Scala project that sits in Scala-IDE 4.5.0 (Eclipse) which uses Scala 2.11.8. In that setup everything is working fine (naturally).

Recently I upgraded to Scala-IDE 4.6.1 which uses Scala 2.12.2. My project failed to build and reported a ton of the same errors of the form:

Error while emitting XXXX.scala assertion failed: not yet assigned: xxx/xxx/xxx

Then I tried running my Ant build-script which we use to create the production builds with Scala 2.12.2 and that fails with a different error:

no-symbol does not have a type constructor (this may indicate scalac cannot find fundamental classes)

I do not know what I am doing wrong but there seems to be something in Scala 2.12.2 that prevents it from compiling my Scala code. Does this ring any bells?



I haven’t had an issue like this, but I also use sbt and don’t use ScalaIDE.

That said, have you tried cleaning and recompiling?

Further, if you’re in a git repository you can have git remove anything from the directory that isn’t under version control. I have, at times, found this to be more helpful than a simple clean. Do not execute this if there are things you care about not under version control. But the command is:

$ git clean -fdx

Sounds like – there are some suggestions on the ticket to help fix the problem.

My Ant build does little more than clean up (delete the output directory used by a previous build) and then call scalac via an Ant task. I am pretty sure the compiler runs from a completely empty environment.

I read that earlier and what I got from it there was a suggestion to include scala-compiler.jar in the build path which resolved some problems for others. I tried that and that does not help.

Additionally they discuss a fix that should be in 2.12.2 which is what I am using. So I am afraid my issue lies elsewhere.